Notices

April 2022

Updated
Regarding Vulnerability Measure Against Buffer Overflow for Laser Printers/Inkjet Printers and Small Office Multifunction Printers

28 Apr 2022 — Regarding Vulnerability Measure Against Buffer Overflow for Laser Printers/Inkjet Printers and Small Office Multifunction Printers Thank you for using Canon Products. Multiple cases of buffer overflow vulnerability have been detected for Canon Laser Printers/Inkjet Printers and Small Office Multifunction ...

December 2021

Advisory for Laser Printers and Small Office Multifunction Printers

24 Dec 2021 — Advisory for Laser Printers and Small Office Multifunction Printers Thank you for using Canon Products. A cross-site scripting vulnerability has been identified in the Remote UI feature of Canon Laser Printers and Small Office Multifunction Printers (Refer to affected models shown below) (Vulnerability ...

November 2021

Updated
macOS Compatibility List for Inkjet Printer / Scanner

15 Nov 2021 — macOS Compatibility List for Inkjet Printer / Scanner   You can check for compatible OS for your specific model by clicking here. Search a model (e.g. "PIXMA iP2772") Select "Drivers, Software & Firmware" Select an OS and "Drivers" under ‘Compatible Operating System’ ...

June 2017

Updated
Windows OS Compatibility List for Inkjet Printer / Scanner

28 Jun 2017 — Windows OS Compatibility List for Inkjet Printer / Scanner   Updated 28 June 2017   List of Products Supported PIXMA TS Series   |   PIXMA G Series   |   PIXMA PRO Series   |   PIXMA iP Series   |   PIXMA iX Series ...

August 2013

Updated
After-Sales Service Support for Inkjet, Inkjet AIO, Inkjet Fax and Scanner

30 Aug 2013 — After-Sales Service Support for Inkjet, Inkjet AIO, Inkjet Fax and Scanner Note:*1: New product model launch after Aug 2013 is not listed here.*2: Those models indicated with "-" means the After-Sales Service Due Date is not fixed yet.*3: If you wish to repair a product model beyond the After-Sales Service ...

February 2008

About Vulnerability affecting FTP Print

29 Feb 2008 — Vulnerability affecting FTP Print It is found that some Canon imageRUNNER, Color imageRUNNER, imagePRESS, LaserShot devices* contain a vulnerability known as "FTP" bounce when configured for network printing. Engines using imagePASS, imagePRESS Servers, or ColorPASS devices for printing are NOT affected ...